DI-524 e seu bug bizarro – Parte 1

No meu último post eu venci a batalha do MTU, mas infelizmente esse roteador é um péssimo perdedor e pediu revanche :(

Após cerca de 20 horas trabalhando normalmente, ele começou a simplesmente ‘não enxergar’ o modem(é o que eu acho :D). Ele não consegue conectar via DHCP no modem, mesmo resetando, mesmo refazendo todas as configurações, mesmo passando o modem para bridge e deixando para o routeador discar, mesmo tentando conectar com ip estático, mesmo a pipoca não tendo antena ele simplesmente não se conecta.

Pensei em atualizar o firmware mas pelo que eu vi no site já estou com a versão mais nova.

Entrei em contato com o suporte da D-Link pelo site, se eles tiverem uma solução então beleza, caso contrario vou trocar ele logo(e vou descobrir se o submarino é bom para trocar também :P).

D-Link DI-524 e problemas de conexão

Hoje chegou meu roteador D-Link DI-524 e pela primeira vez fui configurar uma rede wireless(como se fosse muita coisa :P), entrei em 192.168.0.1, usuário ‘admin’, senha em branco, rodei o ‘wizard’ logo na primeira página, fiz a configuração e ok, rede protegida e funcionando(era o que eu achava).

Meu MSN não queria entrar de forma alguma(mas o XMPP entrava sem problema nenhum), pensei ser problema na rede deles mas, não consegui dar pull no github(embora conseguisse no gitorious). Pesquisando um pouco na internet descobri que nesse roteador você precisa mudar o valor do ‘MTU'(em Home » WAN) de 1500 para 1400.

MTU mudado e agora tudo funciona como deve. Só espero não ter problemas futuros já que o notebook ta configurado com MTU 1500(padrão).

Cuidado com o console.log(), ele pode te causar problemas

Cenário de hoje, o mapa(Google Maps) do sistema que eu mexo estava dando problemas com alguns clientes, mas aqui estava perfeito. Ouvi muita reclamação do meu chefe e com a ajuda do @raphaelivan chegamos a conclusão que o problema era o zoom. Ele ficava com zoom bizarro e ponto final, quando mexiam no zoom ele focava na Somália(Oo).

Por questão de segurança pedi pro raphael ver se no notebook dele o problema também existia, então foi a primeira surpresa: no Chrome estava normal, o problema era com o Firefox.

Abri meu Firefox e o mapa abria normal(estava com o firebug ligado). Como o firebug estava ocupando muito espaço na tela resolvi fechar ele, em seguida me veio a idéia “está normal por causa do cache, vamo ver se com F5 a coisa pauleia”, dei o F5 e o mapa realmente pauleou. Continue reading

Instalando o KDE no Ubuntu

Dica rápida. Como vejo que muita gente chega aqui procurando por Como instalar o KDE no Ubuntu então resolvi postar.

É bem simples, apenas instale o pacote kubuntu-desktop com o comando sudo apt-get install kubuntu-desktop e vá para a tela de login e mude o Session Type/Tipo de Sessão para KDE/KDE4.

Pronto, basta logar normalmente agora.

Resolvendo (parcialmente) o problema de threads no QtRuby4

Bem, comecei a brincar com QtRuby e ja conheci o problema de threads: o QtRuby não tem suporte a threads ainda, nada da GUI pode ser alterada fora da thread mãe e as threads do ruby não rodam enquanto a GUI está sendo executada.

É nessa hora que juntamos todo o nosso conhecimento e o colocamos em prática junto com a habilidade de POG.
Continue reading